Answers 66

From LXF Wiki

Answers 66


<title>Acer in a hole</title>

<question>A while ago I took the plunge and installed SUSE 8.2 with a Centrino wireless card on my Acer laptop. I've since upgraded to 9.2 and have 9.1 Professional installed on my desktop. I expected all sorts of problems with the laptop, but they didn't materialise, except for one major issue ­ I can't get it to talk to anything. That's not quite true ­ it will connect to the internet if I cable it into my Linksys router, but... Neither of my Linux boxes can see one another (I set the Samba server up on the desktop using YaST, and the laptop up as a Samba client). The wireless card won't connect to the internet or see the other computer. I can't get a connection via bluetooth to my T610 phone. Infrared works according to YaST's Test button, but won't do anything beyond this. The inbuilt modem is recognised and dials telephone numbers, but beyond that PPPd crashes - no connection again. I'm on the verge of stripping SUSE off the laptop because it's using up so much of my work time just trying to get connected to deliver work to clients. Why does it have to be so difficult? I'm not a techie but I'm a very competent Windows user. If I could find someone to talk me through this, I'd feel different, I expect. As it is, I only have limited time to trawl the internet and then start tailoring dangerous-looking configuration files. I like Linux and I support open source software and make donations but it's just getting to be too much. If you can help me get wireless and bluetooth operating on my laptop and make my two Linux boxes `see' one another, I'd be mighty pleased. Otherwise, I guess it'll be back to Windows but using as much open source as I can. Your magazine is excellent ­ I'll probably still read it even if I have to say bye bye to Linux.</question>

<answer>The simplest way to solve this problem is to begin at a low level and try to ping hosts on the network. If you can ping the other system by its IP address, then the chances are that the basic network is OK. There are situations where pinging works and file transfers do not, but these are few and far between, and are generally limited to complex network configurations. You can verify the IP configuration and routing on the laptop using ifconfig ­a and route ­n. Your on-board Ethernet will be eth0, and your wireless will be eth1 or wlan0, depending on how the distribution handles wireless access. If you can access the wireless router, but can't get out onto the Internet, then the fault is likely to be a routing issue on the device; either because a default route is missing, or the system is trying to send all traffic out of the wired Ethernet interface. Without information on specific configuration options, and the current state of the system, it's difficult to put my finger on an individual cause of your network problems. Samba on each host will need to be configured via the etc/smb.conf file, so they'll both belong to the same workgroup. Even without this change, you'll be able to access shares permitted in etc/smb.conf by specifying the IP address of the host in the Samba client. Rather than using Samba, file sharing on Linux is better done using NFS, which can be configured using the SUSE system configuration tools, or by editing etc/exports. With all laptops, it's a good idea to start over at www.linux-laptops.net, and see what success others have had with Linux and specific configuration options used. Laptops are, unfortunately, rather strange beasts, and it can be difficult for developers to get their hands on every single variant out there. You may want to give a distribution such as Mandrake or Fedora Core a try and see if you have anymore success. Often, different Linux distributions have kernel patches installed, which resolves any problems interacting with various hardware devices.</answer>

<title>Linux for business</title>

<question>I've got a good one for you. I'm not sure that this can be categorised as a technical question but the only other places I can find answers are bound to be biased. I'm a Linux business user. Most of our back-end servers and services are Linux-based. Our users don't care whether we use Red Hat, SUSE, Microsoft Windows or Baron Samedi-style voodoo ­ they all have Windows desktops and essentially just want to browse the net and get their mail and files. We're upgrading our server hardware, which is extremely dated and is about to fall out of warranty (it's already been End of Life for some time). If fortune favours us we'll be able to do this upgrade one server at a time, so we're not under immense pressure to get the entire network done in one go. We have a decent budget but can't go on a complete shopping spree. Now for the questions: what's the best server hardware to go for if we're looking for Linux compatibility? We'd like the vendor to have official Linux support ­ not just some guy on the net who's got some source for BSD we can try to cross-compile with mixed results. Secondly, is it really worth going for one of the paid-for Linux distros? All our current servers use Red Hat 8, which works pretty well. A Red Hat-based distro would seem an obvious choice but is Red Hat's Enterprise Linux the best option, or would we be better off with Fedora? Having said that, if we're going to be paying money for this, would SUSE would be better? Thanks for your help.</question>

<answer>Wow, an IT department with a budget, fantastic start! Before I give you my view and trigger an onslaught of hate mail please remember that this is only the opinion of one simple man trying to make his way in the universe, based on my own experience with server hardware and Linux distributions. Most of the hardware vendors out there are really very good. I'd say there are two main categories to choose from here. The top tier hardware vendors like Dell, HP, and IBM etc. These guys make phenomenal hardware ­ it's their business to, but many of them only support Linux as an afterthought. From my own experience Dell have it covered on their rack-dense servers. They can offer you Red Hat Enterprise with SUSE preinstalled at the factory, which means you can be confident of having good driver support. Another big company taking bold strides is IBM. IBM has always been a favourite of mine, and with the millions of dollars they're pumping into open source they'd be a safe bet. At the other end of the spectrum you get the true grass roots Linux companies that make their own servers mostly out of commodity clone hardware. There are loads of such companies around, and most of them are small and so give a more personalised service than the big hitters. These companies are built on Linux so providing a product built with Linux in mind is what makes them tick. When it comes to picking a vendor for your software it gets more blurred. Here are the main reasons I would be willing to pay for a Linux distribution:

Updates If a company provides a Linux package they're obliged to keep it running securely.

Support There's someone to call; even if it may cost a little money. Different levels of support are available for different budgets.

Accountability Often the people paying the cheques like to know that there is somebody they can hold accountable for a failure in service, either of the product or any of the ancillary services.

I'll focus on Red Hat in particular as I have no real experience with Novell/SUSE's commercial offering. Red Hat will give you the actual operating system license as well as a subscription to their up2date service for patches. Also, if they release a newer version (such as the upcoming RHEL4) you'll be able to download and install that too. For the approximately £500 standard package they'll answer an unlimited number of queries within four hours during business hours. This level of service can be upgraded all the way to one-hour response times, 24/7. SUSE's free product support will also work very well for you but don't expect anything more than Google for help; you really do get what you pay for when you're talking support. Having said that, if you've been using the free Red Hat product for some time, you can probably support yourself quite adequately whatever distro you go for.</answer>

<title>Hi tension</title>

<question>I have a D845WN Intel motherboard, which (according to the Intel website) has Hi-Speed USB 2.0 ports. Unfortunately I've not been able to attain high speeds, even after installing all the relevant software for my motherboard from the Intel site. I'm running Fedora Core 3 on my machine and have an external USB 2.0 hard disk. Using it on USB 1.1 ports is extremely frustrating. Can you tell me how I can I enable Hi-Speed USB 2.0 speeds?</question>

<answer>USB 2.0 under Linux requires a supported USB 2.0 controller and the use of the EHCI module to access the USB subsystem. You can verify which USB modules your system is loading by using dmesg, which displays kernel information from system boot time. However, what you describe may be related to a problem with the EHCI module itself. The kernel 2.6. 01 source included EHCI driver software which seems to confuse some controller cards (To be fair, the EHCI drivers are still rather experimental). This can cause quite a few problems. The easiest way to fix your woes is to change your kernel. It is possible to go back to an earlier version, but before you try that, check out http://download.fedora.redhat.com/pub/fedora/ linux/core/updates/3/ for updates to the Fedora kernel. </answer>

<title>Zipped off</title> <question>I am a subscriber to LXF and a newcomer to Linux generally. I'm having problems trying to copy the Gambas application from this month's CD [LXF 64]. Using find /mnt/cdrom2 gambas-1.0.1.tar.bz2 -print results in mnt/cdrom2/Magazine/Gambas/gambas-1.0.1.tar.bz2; but adding this pathname to the command tar xvf --bzip2 given in Essential Disc Info generates the error message `btar: --bzip2:Cannot open: No such file or directory'. Replacing 1.0.1 with 2.1.0 in the filename produces the same message. What am I doing wrong?</question>

<answer>There doesn't seem to be anything wrong with the steps you are trying, but the error message suggests your command isn't formated properly try this:

 tar xvf --bzip2 /mnt/cdrom2/
 Magazine/Gambas/gambas-1.0. .tar.bz2
                               1

You can also use the slightly shorter "tar xvfj [filename]" with most versions of tar.</answer>

<title>Samba on SUSE</title>

<question>I'm having trouble getting Samba to work on my SUSE 9.2 box. I use a Belkin 10/100 Ethernet card on my Linux box; a Via Rinefire onboard 10/100 Ethernet card on my Windows box; and a five-port Belkin Ethernet switch. The Belkin NIC is detected and configured by SUSE, but I can't figure out how to get Samba to work. It worked under my old system (Fedora Core 3) but I don't want to go back to this, as I want to listen to MP3s and use the software (like Scribus and KMyMoney) that comes with SUSE. Any help would be appreciated.</question>

<answer>You'll need to verify that Samba is running and that the firewall is turned off ­ use YaST for this. If the firewall is enabled, remote systems will be unable to access the Samba service. As an alternative, you can open up specific ports on the firewall to permit access to Samba:

TCP: 137, 138, 139, 445
UDP: 137, 138

Put the following lines in the etc/sysconfig/SUSEfirewall2 configuration file:

FW_SERVICES_EXT_TCP="microsoft-
ds netbios-dgm netbios-ns netbios-
ssn"
FW_SERVICES_EXT_UDP="netbios-
dgm netbios-ns"

You will also need to enable broadcast

packets on the firewall:
FW_ALLOW_FW_BROADCAST="yes"

Et voila! Hope this works. </answer>

<title>Missing modem</title>

<question>I have just installed SUSE 9.2 from the March 2005 issue [LXF64] as a dual boot alongside Windows XP Home, which I still use. I am completely new to Linux, and the installation couldn't have been easier. There are, however, some questions I can't easily find answers for on the net. YaST has recognised most of my hardware, graphics, sound etc, including the fact that I have a USB ADSL modem. But it doesn't recognise the modem itself just the fact that I have one. When I click on the modem entry in the hardware list, the Configure button stays greyed out. The modem is a Sagem Fast 800/840, which I have connected via USB rather than Ethernet card. There are instructions for Linux on the modem's install disc, but I'm afraid it's all a bit over my head. Is there an easy way to install this modem on SUSE? Are there simple instructions in newbie terms? More importantly, if I configure the modem for SUSE, will it still work when I switch to Windows to go online from there? Can it be used on both OSs without problems? My ISP is Tiscali, and I connect on a 512k broadband connection. Are there any problems from Tiscali's side if I connect with both Linux and Windows? Also, where do I find the options for setting up an internet connection in SUSE? (ie is it as simple as it is in Windows?) And is email set-up similarly pain-free? With anticipation of some help for a helpless Linux new boy, thanks very much.</question>

<answer>We were able to find some documentation on the configuration of this modem with Linux, although it is fairly complex ­ and in French. You can find it at http://lea-linux.org/hardware/sagem.html?v=t. You'll be able to use the DSL modem from both Windows and SUSE as you dual-boot, although your ISP probably won't support the connection for Linux ­if it doesn't work, don't expect them to help you. Configuration for internet connectivity via supported devices in SUSE is performed through YaST, so if you have any internal Ethernet connections, or a dial-up modem, you can set them up this way. You have quite a choice of mail clients ­ we would recommend Thunderbird from www.mozilla.org, which is a great client with an easy to use interface.</answer>

<title>More SUSE stuff</title>

<question>I've just installed SUSE 9.2 from your latest DVD. I religiously installed each of the main distros as you published them, hoping against hope that I would eventually have a Linux platform which would allow me to connect to the internet. I have a broadband connection via Wanadoo using an Alcatel SpeedTouch USB modem, which looks rather like a green, limbless crab. I was able to connect with this modem back in the days of Mandrake 8, but have been unable to connect since upgrading. I've tried Mandrake, SUSE, Fedora and Red Hat, all to no avail. Can you please help me, or (if I need to purchase a different modem) recommend one that SUSE will recognise? I would be forever in your debt ­ as would be my barber once I stop tearing my hair out.</question>

<answer>Lots of information on the Alcatel SpeedTouch USB modem (otherwise known as `the frog'), can be found at http://linux-usb.sourceforge.net/SpeedTouch/. This includes open source versions of the drivers, as well as setup documentation to get you onto the internet using the modem. As you are running SUSE 9.2, you can follow the instructions at http://linux-usb.sourceforge.net/SpeedTouch/suse/index.html to get it up and running. Wanadoo gives you the option of using either PPP over Ethernet, or PPP over ATM (PPPoA); but the SpeedTouch USB documentation suggests that using PPPoA is a better option. In either case, you'll need to follow the specific instructions for the PPP method used to connect to your ISP.</answer>

<title>Unsupported</title>

<question>I would like to upgrade from MySQL 3.23 to MySQL 4, but my Red Hat Enterprise Linux ES server does not have the relevant package available. I can see that a package is available from the MySQL site but I'm worried that it will break my server. Can you give me any advice on this job? I know how to do the actual install of the RPM ­ I just don't know what the consequences will be.</question>

<answer>The upgrade itself should pose no problems. However, please bear in mind that the RPM from MySQL will probably have a different username to those used by the Red Hat version, as well as some different paths. Any third-party programs you have that go into the MySQL 3.23 libraries may also need to be updated. The table structure between 3.23 and 4.x is totally compatible, but the MySQL table has a few extra columns that will need to be added. There is a script included in MySQL called mysql_fix_privilege_tables which should resolve any issues with this. One thing to think about before you go through with the upgrade is that Red Hat does not officially support MySQL 4 ­ so you'll lose all support for this aspect of your operating system. I've seen this combination work many times, but if you decide to go ahead don't forget to add MySQL to the up2date ignore list, or you will automatically downgrade to 3.23 next time up2date runs.</answer>

<title>Wi-Fi gear</title>

<question>I've been running Mandrake Linux 8.2 with Windows 98 SE on my PC. After five months of running both, I've decided to get rid of Windows and the partitions, and use Linux full-time. I have just bought your Complete Linux Handbook 2, and intend to install Mandrake 9.2 from the DVD. I've ordered 2MB broadband (without tech support) from Madasafish, who cater for Linux, and I want to use a wireless connection to my PC as it will not be staying where it is. Can you advise me on a wireless modem/router? Would I be better off with two separate units, and will I need some sort of a card in my PC? I'm not having any luck finding something suitable on my own (not knowing what I'm looking at doesn't help). The products need to be reasonably simple for someone as ignorant as me to set up. Any help you can give me would be gratefully appreciated.</question>

<answer>LXF would recommend you start out by installing a recent distribution of Linux, such as Mandrake 10.1 or Fedora Core 3, rather than trying to fight with something a year or two old. You can find a list of wireless devices that work with Linux from www.prism54.org, and you should probably pick a DSL router from the vendor that you're purchasing your wireless adaptor from. As you have LUG nearby [Malvern], you may wan to join their mailing lists and find out what success others have had with specific devices. You can either purchase a wireless bridge, which provides wired Ethernet access to your device, or a PCI card which has a wireless adaptor built in. Many manufacturers (including D-Link and Netgear) make DSL and wireless devices, so you have quite a selection to pick from. There are also a number of low-cost vendors ­ we recommend that you avoid these, otherwise trying to find support from a LUG or on the internet is going to be quite a trial.</answer>

<title>Say what?</title> <question>I'm a newbie with regards to Linux, but with the offer on your cover of SUSE 9.2 I thought I'd give it a try, and set my machine up to dual-boot both Windows 98 SE and SUSE 9.2. I must say I'm very impressed. The install was a lot easier than Windows' and I'm thinking of doing away with Windows altogether. The only thing stopping me is the inability to get my onboard sound working. My PC specifications are:

AMD Duron processor running at 1,600MHz.
512MB DDR RAM.
ASRock K7VT2 motherboard with onboard sound, LAN, USB 2.0, etc.
Maxtor 40GB HDD.
Bearpaw 1200Cu scanner.
Epson 810 Colour Stylus photo printer.
Compaq Presario 1425 monitor.</question>

<answer>The ASRock K7VT2 motherboard uses a VIA chipset, which has onboard AC97 compatible audio. If you are running a 2.6 version of Linux you can add the following to your /etc/modules.conf file:

#--- START ALSA ---#
#--- ALSA ---#
alias char-major-1  16* snd
alias snd-card-0       snd-via82xx
# (sound-card-0 is probably not
needed, but just in case)
alias sound-card-0 snd-card-0
#--- OSS ---#
alias char-major-14* soundcore
alias sound-slot-0 snd-card-0
#--- ALSA - CARD ---#
options snd           cards_limit=1
#--- ALSA - OSS ---#
alias sound-service-0-0 snd-mixer-
oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-
oss
alias sound-service-0-8 snd-seq-
oss
alias sound-service-0-12 snd-pcm-
oss
#--- ALSA - /dev (OSS) ---#
alias /dev/sequencer* snd-seq-oss
alias /dev/dsp*      snd-pcm-oss
alias /dev/mixer* snd-mixer-oss
alias /dev/midi*     snd-seq-oss
#--- END ALSA ---#

Once the audio device is accessed, it will automatically load the modules for you.</answer>

<title>Lost in firmware</title>

<question>I finally have a broadband connection thanks to a USB SpeedTouch 330 modem, which, according to a multitude of pages on the internet, can be used with Linux. Here is the problem: they all mention that I need to download firmware and perform several steps with the firmware in order to get the modem working. My understanding of the meaning of firmware is that it is the software that sits on the modem itself; so if I carry out the instructions as spelled out on http://linux-usb.sourceforge.net/SpeedTouch/fedora/index.html for Fedora Core 3 I should end up with a working modem for my Fedora Core 3 system. If I have to update the software on the modem to get it to work with Linux, will it stop the modem from working with my existing Windows XP installation? I really don't want to proceed any further until I find this out as flashing things like BIOS/firmware scare the living daylights out of me!</question>

<answer>As the firmware is distributed by SpeedTouch, you shouldn't encounter any problems when you use the modem under Windows XP. As always when doing any firmware or BIOS upgrades, you should ensure that you have a backup of the existing image ­ in fact, this should be at the top of your to-do list. Most likely, if something goes wrong when you try to update, you'll have to send the whole thing back to SpeedTouch for them to fix it for you. We've rarely had problems ourselves with flashing devices, other than if there is a hardware issue on the device which corrupts the image. We think it would be fine to flash the modem, although you may wish to check with the nice people in SpeedTouch's technical support department first to verify that the image will work.</answer>

<title>RAID distress</title>

<question>I have been experimenting with Linux for the past two years and would consider myself to be an enthusiast ­ if only at quite a basic level. I recently purchased a new computer from MESH and decided to opt for an AMD 3200 Athlon 64-bit processor on an ASUS K8VSE Deluxe motherboard with the intention of installing my favourite distribution, SUSE Professional 9.2, in dual boot mode with the pre-installed Windows XP. This is where the problems started. The motherboard has an on-board Promise FastTrak 378 controller, which the 200GB SATA hard drive was configured to use in a RAID 1+0 array. When I tried to install SUSE Professional 9.2, having made space on the hard drive using Partition Magic from the Windows XP OS, the installation procedure advised me to disable the hardware RAID 1+0 array and to create a software RAID 1+0 array within SUSE using YaST. I was concerned that if I did this I would not be able to use the Windows XP OS installed and therefore have not been able to install the SUSE distribution. The ironic thing is that I do not need to have the computer configured to use the RAID 1+0 array as I only have one hard drive installed. I would like to know whether it is possible to install SUSE Professional 9.2 in dual boot mode with the pre-installed Windows XP o/s or whether I have to re-build the computer from scratch not using the Promise drivers during the installation and not configuring a RAID 1+0 array? I have also installed a separate 40GB ATA hard drive connected to one of the motherboard's IDE connector's to see whether I could install SuSE on to this drive but was not successful. I would be grateful for any advice you could give me.</question>

<answer>We're rather confused as to why the Promise FastTrack controller would let you create a RAID device with a single disk, much less a RAID 1+0 array, which requires at least four disks. You can try to disable any RAID capabilities in the FastTrack BIOS, and as you've only got a single disk, the BIOS should boot from it quite happily. SUSE will detect the RAID array as a device, and allow you to partition and write information to it. As a test, you can boot using a Knoppix 3.7 CD, or attempt to install Mandrake 10.1 or Fedora Core 3 which may have better support for the SATA controller on your board. Many boards that provide SATA only recognise certain ATA controller ports. If you can't install SUSE onto an ATA disk, there is probably a misconfiguration within the BIOS. You can try to turn off `Legacy Mode', to allow both SATA and ATA to work on their own: Legacy Mode is designed for older Operating Systems that get confused when SATA is available.</answer>

<title>Zip it</title>

<question>Thank you for SUSE 9.2 on the LXF64 DVD. However, I've had to revert to 9.1 as I couldn't get my Zip drive to run on 9.2 ­ the Iomega Zip drive wasn't even identified. I give below the entries I made in /etc/fstab:

/dev/hdb 
hdb4 /media/zip subfs
auto auto
noauto,fs=floppyfss
{nothing},procuid,exec, user
nouser,dev\nodev,rw

I think you'll agree I tried all reasonable combinations. Some of them merely echoed SUSE's entries for /dev/fd0 (floppy disk). I liked everything else about 9.2 and so am disappointed not to be able to use it, but my Zip disks are my main archive at the moment, and contain a lot of data. Thanks for your time and attention! I do hope you can help.</question>

<answer>You should start by verifying that the Zip drive actually exists by running dmesg. This will output a whole slew of information, which should hopefully include IDE devices located during the boot process Assuming the device really exists on /dev/hdb, you need to mount /dev/hdb4, which can be done manually with the following:

mount ­t vfat /dev/hdb4 /media/zip

If this fails to mount the Zip drive, the error output should indicate what causes the problem fairly quickly. Should it work, you can add it to fstab with the following:

/dev/hbd4 /media/zip auto  defaults 0              0

You can then manually mount the device with the command:

mount /media/zip

Good luck!</answer>

<title>What a mate</title>

<question>I have been trying to set up a Linux box running Fedora Core 3 for my friends to play with. They're mostly Windows guys and don't have a lot of command-line experience, so I'm trying to help them into the wonderful world of open source by setting up VNC on the Linux box so they can log in and play around on separate X session. I have created a script called vnclogon to start a VNC server session but am having a lot of trouble making it work. The script is as follows:

#!/bin/bash
echo "Hello There "$USER
echo "You are about to run the
VNC server service."
echo ­n "Do you want to
continue...(Y/N)"
read Decision
if [ "$Decision" = "Y" ]; then
         echo "Starting your
VNC Session."
         echo "Please wait..."
         vncserver :1 ­name
$USER >/dev/null 2&>1
echo "VNC Session Loaded!"
else
         echo "Then why did you
run the script?"
fi

The strange thing is that the script seems to execute correctly but when someone tries to connect using a VNC viewer they get the following error: `Unable to connect to host: Connection refused (10061)'. Even stranger is the fact that when I try to kill the VNC session by using the vncserver ­kill:1 command, I get the following error: `Killing Xvnc process ID 4790, Kill 4790: No such process'. The strange thing is that when I run the VNC server service manually, I manage to connect. Please help me make this work.</question>

<answer>You seem to have a nice script going and I admit that I was a bit puzzled by the error you got when you tried to kill the VNC session generated by the script. It appears that you've tried to suppress the output generated by VNC when a VNC server session is launched by redirecting the output to dev/nul using I/O redirection. The mistake is in the syntax of the command ­ instead of >/dev/null 2&>1, you should have typed >/dev/null 2>&1. The 2>&1 is actually a neat piece of code which is used to send standard error to the same place as the standard output. You've sent your standard output (1) to /dev/null, and so standard error (2) also goes to /dev/null. The & in 2>&1 is simply to put the job in the background so that you get your shell prompt back. All in all the script seems quite good and I believe that this correction should help solve your problem and allow your friends to make better acquaintance with Fedora Core's X front-end.</answer>