Answers 61

From LXF Wiki

Answers_61


<title>Upgrade or stick?</title>

<question>A couple of months ago I bought the Complete Linux Handbook 2 with the Mandrake 9.2 distro on the DVD, and decided to install it. Since then I have spent a very long time teaching myself Linux; most of the time has been getting all of my peripherals to work. Needless to say my Winmodem took by far the longest. Now I'm at the state of actually doing stuff, instead of configuring stuff. The OS is absolutely fab, and recently I changed my default boot option from WinXP Pro to Mandrake (yay!). Now I notice that in October's magazine there will be a copy of 10.1 available. Will upgrading simply be a case of putting the disc in, clicking a few icons and supping a cup of tea, or will the arduous task of setting up all those peripherals, software, etc, have to be repeated? Great mag by the way. </question>

<answer>The short answer to your question is yes ­ if you upgrade, you will spend more time reconfiguring stuff. But perhaps not everything. Mandrake handles upgrades by simply upgrading the packages you have on your system. If you have KDE3.1 installed, and the new version contains packages for KDE3.2, it will simply update the rpms. Theoretically, any configuration files you have will remain the same. Unfortunately, other changes in the OS may cause the upgrade not to be so smooth. As an example, the 10.1 release uses X.org as opposed to Xfree86 for the x server ­ so it's not just a version upgrade. Some of the base Mandrake packages also change the locations of some files, and may over-write configurations. On the plus side, the newer OS will probably recognise a lot more of your hardware and configure it straight off ­ but only if you do a new install. Ultimately, though, you will need to upgrade if you want to keep getting packages for your system that you can actually use. The best idea is to create some space or use an extra drive and install the new Mandrake alongside the old one, then work out what stuff you need to re-implement. </answer>


<title>External CDR< title>

<question>I have started to migrate from Win2K to SUSE Linux 9.0, but can't start to install personal data in my partition until I'm able to back it up. Though I have tried to test the CD software K3B, I have an external HP 8200 series (8220e/8230e) USB CD writer, for which I need a device driver. I've searched the web and checked HP's website, but without success. Where can I get a suitable driver? </question>

<answer>There are two prerequisites for burning CDs under Linux: the device itself must be accessible, and the burning software must understand the protocols used by the drive so it can format the data to be written. In the case of an external CD drive, the first is taken care of by the USB mass storage driver. This will just work, in general, and Linux certainly shouldn't have any trouble recognising this device, which will be set up as an emulated SCSI drive. The second requirement is usually fulfilled with Cdrecord. It seems that your drive is supported with Cdrecord from version 1.10, so assuming you have that, it shouldn't be a problem. Tools like Xcdroast and K3b are merely front-ends to various tools, and will use the version of Cdrecord you have for actually writing discs. To check that your drive can be seen, open a terminal and type:

<command>

cdrecord -scanbus

</command>

You will hopefully see, among everything else, a line that begins with three numbers and includes some text identifying the drive. If K3b isn't recognising the drive, try running usbview to check that it is being picked up by Linux. </answer>


<title>Camera tricks</title>

<question>I've bought a new digital camera, a Pentax Optio 430 RS. My reasoning was that the old (about five years) Pentax digital of my brother's had connected to my first Linux box (an old P1 233 running RH 7.1) perfectly ­ all I had to do was something like "modprobe DC200", plug in the USB, switch on the camera and mount it. Foolishly I thought that my new system ­ Mandrake 9.2, updated almost weekly and running kernel 2.4.22-21 ­ would have no problems. Silly, I now know! I checked your article in LXF21, but things seem to have changed a bit since then! I've trawled your forums, but no one is using the Pentax. I've looked at the Pentax website ­ no reference to Linux. I've Googled, and the only relevant references I can find tell me to upgrade and recompile to kernel 2.4.20 or above". I'm using 2.4.22-21, does that not qualify? I just don't know which way to go now, even the order that one does things in eludes me. I'm not an expert Linux user ­ I'm a cabinet maker. I use Linux because I hate the Gates concept of continually paying for your computer, and I like free' things. Please could you give me a 1... 2... 3... on how to make this work. </question>

<answer>The problem is likely to be that the camera is simply not recognised by the drivers. Every USB device has two IDs ­ a manufacturer and a product ID. This is used by the driver subsystem to match a driver to attached devices. Confusingly, sometimes the numbers stay the same across similar devices, and sometimes they change. The most likely reason your camera doesn't work is that your particular model has no pair of magic numbers entered in the USB drivers. Curiously though, your model is listed as working with the USB drivers. Try using usbview (it is included in most distros) to check whether the camera is recognised or not ­ the ID numbers listed for this device are 0x0a17, 0x0004. If yours are different, it may be a variant not accounted for in the driver. You can find out lots more info on cameras and Linux at http://www.teaser.fr/~hfiguiere/linux/digicam.html. </answer>


<title>Boot magic</title>

<question>Firstly, a big thank you and apology to all who helped me out with my scanner woes some time back. Sorry for not replying; I took some time out to start a family. Family fine, scanner still only works if I boot into Windows first. Anyhow, I need a hand configuring my dual boot setup (XP service pack2 on one drive, Mandrake 10 on the other). I currently use a boot disk to boot Linux, but would like to dispense with that and have a boot menu where XP is at the top as a default boot (for the non-Linux users and gamers in the house) and have Linux second for me. I need this to be as painless as possible for the windows users (and for me)! Any advice would be appreciated, thanks in advance. </question>

<answer>The easiest way to do this is with Lilo. Grub is good too, but Lilo is a little easier to understand. You can do this the hard way by creating a lilo.conf file by hand, or since you are using Mandrake, you can use the Control Centre to do it for you. Go to the Boot>boot loader section. Select the Lilo bootloader and install it on your main hard drive (probably hda1). Mandrake will usually detect the presence of Windows. Highlight the windows entry and select modify ­ then set it to the default. </answer>


<title>Catux confusion</title>

<question>I wish to use Catux-USB from the coverdisc of the November issue. My problem is how can I install the ISO image on to a USB pen drive? The CD writing software I'm using (Nero) only gives me the option to install to the CD-W drive and not to the pen drive. I have access to another version of Linux (Morphix) which I could use. </question>

<answer>The ISO image inside the Catux distribution is for Catux itself to use. You don't need to burn the software to a disc, just copy all the files in the extracted `catuxusb-0.1a-128' directory on to your USB drive.</answer>


<title>Dell and 54g</title>

<question>I have a Dell laptop running FC2 with a Netgear WG511 card. I've downloaded and installed the Prism54 driver and firmware, and worked through the Linux Unwired book, setting all the config files, etc. I've also worked through Negus' Linux Bible for FC2, and trawled the net looking for help. The card is set not to come up on boot but on PCMCIA services start. On startup everything works, the eth0 interface comes up, the green light comes on the card and the yellow light flashes encouragingly every now and then. When I start up Mozilla the icon to the bottom right tells me I'm online, but I still can't open any pages ­ I get an error message saying "not available, check spelling". I'm very happy with my Linux system and am now a Microsoft-free zone, but this is driving me nuts! </question>

<answer>Linux support for 54g Wifi networking is still somewhat nascent, but, that said, your card should be supported by some of the current driver schemes. (Beware though, wifi manufacturers are well-known for changing chipsets even on the same model of card.) If indeed the lights are coming on, particularly the data light, it would seem that at least the card has been detected and has been prompted to communicate, but what you need to do is fathom what exactly the problem is before you attempt to solve it. There are various possibilities ­the driver may not be working, the driver may be working but be misconfigured, or the card is configured but the network isn't set up properly, and so on. The wireless tools are very useful for determining if the card is working or not. Just type:

<command>

iwconfig

</command>

in a terminal. This will list all the known networking devices and either report "no wireless extensions" or give a list of wireless parameters for the card. If your device isn't listed here, then either the correct module isn't loaded (presumably you are using the ndiswrapper method) or it isn't working - probably a driver problem. If the card is listed, you need to check that the parameters are correct. Try looking at the man page for iwconfig for the settings. At the very least you will need to have the ESSID set up, and any encryption key configured to connect to the access point. </answer>


<title>Via drivers</title>

<question>Is there a Linux driver for the built-in graphics in the KM400/A? </question>

<answer>I like short and to the point questions. The answer is yes, but it depends what distro you are using. Go to www.viaarena.com/default.aspx?pageID=2&Type=3 to access the drivers for Fedora, Mandrake, Red Flag, Red Hat, SUSE and some non-specific options. </answer>


<title>Intel Only?</title>

<question>I have finally gained the intestinal fortitude to have a go at using Linux. I have been interested in the concept of Open Software for some time and I use Firefox, Thunderbird and Open Office as my main programs of choice. While I like to think that I am reasonably computer literate, (I am 69 years of age), and I assemble my own computers, I am a bit perplexed on one point. I use mainly AMD processors for my computers and I have found that almost all of the Linux distros I am interested in ­ Fedora or Red Hat ­ seem to call for an Intel-based computer. My question is ­ can I install Linux on my AMD-based computers or would I require an Intel processor? </question>

<answer>All of the distros you mention will work quite happily on AMD processors, as should any others. The requirements quoted are often confusing in several respects, and when `Intel' is specified, it usually means that the processor must follow the Intel architecture, IA32. This is the case for AMD and many of the other drop-in replacements for Intel processors, such as those made by VIA and others. There are very few differences in the capabilities of these processors, which are normally limited to multimedia extensions such as MMX or 3DNow! These will make very little difference to all but a few applications. </answer>


<title>Loaded laptop</title>

<question>Hope you can help! I have a laptop which is not being used, but I would like to replace Win98 with Linux. It is a Sony pcg745 with a Pentium 266MHz with MMX, 128MB of memory and a 3GB drive. I have unzipped SUSE 9.1 from a magazine, but have also purchased your November issue to help me with this. I'm unable to find out how to get rid of Win98 altogether and totally replace it with LINUX. The laptop has a CD drive and floppy drive, but no DVD drive. Any help with this would be most helpful.</question>

<answer>With such a configuration you may need to be a bit careful about what software you install. It isn't a huge amount of memory, and not exactly a cavernous hard drive, so you may not want to install all of KDE 3.3, OpenOffice.org et al. Having said that, though, pretty much all the current distros will install on that equipment. The trick to removing Windows is simply to delete all the partitions on the disk during the Linux install. Some of the new distros may not let you do this by default as a precaution, but there will usually be an `Expert' or `Custom' option when partitioning the hard disk. Simply delete all the partitions before creating new Linux partitions. On this limited drive, I would recommend a 256MB swap partition and the rest formatted as one `/' partition.</answer>


<title>Burn Time</title>

<question>I have recently obtained a new DVD-writer. I don't have the box or anything, as I got it from a friend who upgraded to dual-layer. I didn't think I'd have too much trouble using it with K3b, dvdtools and so on but there seems to be something wrong. It is quite happy reading and writing CD-Rs and CD+Rs with Linux. It will read DVD-Rs burnt on other equipment, but when I try to burn any DVDs myself I get spurious error messages, sometimes telling me that there is no disc in the drive or the `media is not ready'. Any ideas or is it just broken?</question>

<answer>From what you say, there are two possibilities that spring to mind. Either the DVD writer isn't supported by dvdtools (pretty unlikely) or the writer doesn't like the brand of disc you are using. Many manufacturers only approve a small list of media ­other discs will simply not show up when you put them in, which is exactly the problem you seem to have. Find out who made the drive, and look at their website for more info, or try a range of cheap DVD-Rs and see if any work. </answer>


<title>Account admin</title>

<question>Do you know of a decent user email account manager to allow someone of less technical knowledge to administer email accounts via a web-based control panel? We've set up sendmail on our server and can happily add accounts ourselves, but they want control of this. </question>

<answer>This really depends on what you want to do. If you want to make a single adminstrator responsible for every user on every domain or have an administrator for all the users on each domain, then you can use Webmin. Webmin comes pre-installed on all Rackspace's servers, but if you want to load this elsewhere you can download it from www.webmin.com. If you would like to give each user control of their own account, I can recommend two options. On the free software side there is Usermin (from the makers of Webmin). This allows users to change their passwords, set up mail forwarding, configure SpamAssassin and set up fetchmail, and that's just the mail aspect of Usermin. If you're looking for an officially supported commercial product, then take a look at Plesk. Plesk is a full virtual hosting control panel, and you can delegate control to users for many things, including mail. Bear in mind that running Plesk on Linux is less like running Linux and more like running a "Plesk Appliance". You cannot fully control the underlying Linux back-end like you used to. </answer>


<title>Server is sluggish</title>

<question>I just got a new dual Intel Xeon Linux machine running Red Hat Linux 3.0ES, MySQL 3.23.58,PHP 4.3.2 about two months ago. I use it to process and manipulate data, but it seems very sluggish most of the time. Here is a recent top output. I have a feeling that the problem lies in the extremely high iowait, but I'm not a server pro so I could use some help diagnosing my problem.

10:03:09 up 12 days, 20:07, 1 user,
load average: 4.87, 3.76, 3.03
73 processes: 72 sleeping, 1 running,
0 zombie, 0 stopped
CPU states: cpu user nice system irq
softirq iowait idle
total 25.6% 0.0% 6.8% 0.0% 1.6%
340.4% 24.4%
cpu00 20.7% 0.0% 1.9% 0.0% 1.9%
65.3% 9.9%
cpu01 1.9% 0.0% 1.9% 0.0% 0.0%
93.0% 2.9%
cpu02 1.9% 0.0% 2.9% 0.0% 0.0%
91.1% 3.9%
cpu03 0.9% 0.0% 0.0% 0.0% 0.0%
91.0% 7.9%
Mem: 1027996k av, 1012136k used,
15860k free, 0k shrd, 35760k buff
700900k actv, 132820k in_d,
14184k in_c
Swap: 1052248k av, 125840k used,
926408k free 739172k cached
PID USER PRI NI SIZE RSS SHARE
STAT %CPU %MEM TIME CPU
COMMAND
21366 ishop2 16 0 6016 3544 576
S 22.7 0.3 130:01 2 php
31523 root 24 0 2336 1992 1   196 D
1.9 0.1 0:10 3 sendmail
2974 mysql 15 0 78792 61M 1084 S
0.9 6.1 4665m 0 mysqld
31488 ishop2 15 0 4276 3276 772
S 0.9 0.3 8:49 1 php
753 ishop2 23 0 1244 1244 912 R
0.9 0.1 0:00 0 top
1 root 15 0 512 472 452 S 0.0 0.0
0:12 3 init
2 root RT 0 0 0 0 SW 0.0 0.0 0:00
0 migration/0
3 root RT 0 0 0 0 SW 0.0 0.0 0:00
1 migration/1
4 root RT 0 0 0 0 SW 0.0 0.0 0:00
2 migration/2
5 root RT 0 0 0 0 SW 0.0 0.0 0:00
3 migration/3
6 root 15 0 0 0 0 SW 0.0 0.0 0:00
0 keventd
7 root 34 19 0 0 0 SWN 0.0 0.0
0:00 0 ksoftirqd/0

I only have a single 73GB SCSI drive in the server now. My feeling is that the disk just can't handle the requests for info. Would a RAID solution improve my situation? During this top output the server is only running two of my processing scripts and the iowait is through the roof. I could get the exact same numbers if I were running seven or eight scripts instead of two. Any thoughts or suggestions would be appreciated. From the Rackspace Forums </question>

<answer>Without getting on your box and looking closer using vmstat and iostat, I would recommend disabling hyptherthreading by adding the "noht" option to the grub.conf kernel line:

default=0
timeout=10
splashimage=(hd0,0)/grub/splash.
xpm.gz
title Red Hat Enterprise Linux
(2.4.21-4.EL)
    root (hd0,0)
    kernel /vmlinuz-2.4.21-4.EL ro
root=/dev/hda2 noht
    initrd /initrd-2.4.21-4.EL.img

Save and reboot. Test it again and see how it's working. If this makes a difference you may want to also turn hyperthreading off in the BIOS. If the I/O problem is hard disk related, then moving to RAID may help. Again this all depends what type of I/O is causing the bottleneck. A RAID 0 is very fast on both reading and writing, but offers no redundancy, in fact you are more likely to lose data as you have multiple points of failure instead of just one. RAID 1 offers the best read speeds, but you're limited to using two physical disks ­ not great if you need lots of space, and with a whole disk wasted not the most efficient price-wise either. RAID 5 is very common and is easy as well as cost effective to implement. It offers very good read speeds, but writes are a little slow. </answer>


<title>Seeing no change</title>

<question>Hello ­ I'm having a problem with chmod in two areas. I generally use WS_FTP PRO to upload files, and sometimes have to change the mode after uploading. The first problem I'm running into (and this has never happened before, with 35 sites running), is that a certain file will not change... I get permission denied. I also get that if I try to re-download it back to my computer. The dir it is in is set to 777 and I can set the chmod of another file in that dir. So basically Linux will not let me change the mode on this one file. Any ideas? Also, if I try to CHMOD thru php it tells me:

Warning: chmod failed: Operation
not permitted in
/home/httpd/vhosts/etc...etc on line
65

I think this is due to a php.ini setting... Please Help! </question>

<answer>I believe that both problems are related here. It sounds like the file that you are trying to chmod isn't owned by you, and you are not in the group perms of the file. Try examining the ownership of the file you are able to change. That's the owner/group combination that is allowed to change those files. When files are created, you need them to all be owned by the same group, and then make sure that the group has write permissions. For example, if the directory's owner/group permissions (and all subfiles) need to be "root:apache 775", then you need to do a:

<command>

chown -R root:apache dirname

</command>

and then to set the SGID and sticky bits to enforce this, do a:

<command>

chmod 3755 dirname ; chmod -R 755 dirname/*

</command>

(if there are more subdirs, thecommand is a bit more complex). This will set up the "dirname" directory with the proper user/group perms for a shared upload environment. </answer>


<title>USB storage</title>

<question>For some time I have been looking to upgrade from Win98 to Linux, but was reluctant to modify my computer running Win98. A few months ago I was given an old Dell Optiplex with PII processor, 4GB hard disk, 128MB RAM and CDROM drive, running Win95. By a happy coincidence Issue 51 of Linux Format that month contained a live CDROM of MandrakeMove, and running this showed me that Linux would work on the Dell, and pick up all its features. I used MandrakeMove on the Dell to learn more about Linux, and when you produced the issue with Fedora Core 2, I decided to make the Dell a Linux machine. Loading Fedora Core 2 went more smoothly than I expected, and more smoothly than some reloads I have done. Later I was given a USB memory stick and found it very useful on my main Win98 machine, so I decided to try it on the Dell. By this time I had learned enough about Linux from your magazine to work out what I had to put into the fstab file and the mount point, and it worked on the first boot into Fedora. Now I was really getting bold and decided to see if the USB Zip 250 drive from the other machine worked on the Dell, and loaded MandrakeMove to see if it was detected. There was a success and I deduced that the Zip drive for some reason was /dev/sda4. I put this into the fstab file with a mount point and changed the USB memory stick to sdb1, feeling very clever. It was then that I got into trouble. Fedora saw the Zip drive, which worked, but did not see the USB stick in the other USB slot. I went back to MandrakeMove, but was very disappointed to see that it too saw the Zip drive, and it worked, but it too no longer saw the USB stick. Without the help of a crib from MandrakeMove I am now stuck. Please can you help? </question>

<answer>The USB storage driver, responsible for mounting devices such as USB keyring drives, hard disks, some cameras, optical drives and anything else storage related, has a hard job to do. Part of the problem is the hotplug nature of these devices ­they can be attached and removed at any time, and to these ends your drive may not always end up with the same designation, particularly if you plug them in after the system has started. The likelihood is that the drive is being recognised, but is mapped to a different address. The only real way of knowing where it has been put is by looking at the kernel messages. Using:

<command>

dmesg

</command>

will show you the system messages, but there is a lot of junk in there. However, being cunning, we know what it should say, so we can filter the output:

<command>

dmesg | grep `SCSI device'

</command>

This filters the messages to see only the lines that contain text we are interested in. You should see something like:

SCSI device sdb: 128000 512-byte
hdwr sectors (66MB)

Here we can see that the device has been attached as `sdb' but it could be any other available slot. The reason the Zip uses sda4, or the fourth partition of any drive, is a throwback to the multi-platform support of Iomega devices, which keep special Mac stuff on the first partition. </answer>


<title>SUSE and KDE</title>

<question>I would like to commend you on a great magazine. The magazines in the US don't cover the OS like you do, with something for everyone. I have SUSE 9.1 installed on my computers at home. The boxes all have KDE 3.2.1 installed. The SUSE web page has KDE 3.3 to download. I have downloaded all the required files. Now, how the heck do I install it? YaST doesn't let me see the files or maybe I am doing it wrong. If I use rpm, I have problems with conflicts with installed files, missing dependencies, or some files need updated packages in order to continue with unpacking. Please can you suggest another course of action? Also, I have noticed that some flavours of Linux (under KDE) make use of the Windows key on the keyboard to activate the menu. SUSE linux doesn't permit it or activate it. Now, it works with my laptop but not my desktop. I compare KDE settings and don't notice anything different. Mandrake does let you use the Windows key to activate KDE menu... How do I activate it? Is there any way to activate the internet keys? </question>

<answer>If you have already downloaded the packages, then you need to set up YaST to look for them. There is an option to add a new source of packages ­ point this at the directory where the downloaded files are. X actually controls how the keys are mapped, but assuming the key you want to use is recognised under X (the Windows key is usually mapped to `F13') then you can change the use of the key in the KDE control centre. Launch it and open System>Khotkeys. SUSE should already be set up to pop up the K Menu with Alt+F1. </answer>


<title>Call for answers</title>

<question>Hi, I have an application running on a Microsoft-based system that allows me to record telephone voicemails directly into an SQL database. People can send messages to friends, who can either phone in to pick them up or receive them from our website (streamed back to them) or request them over email. I've moved all the code from ASP to PHP, but I'm not certain how to handle the phonecall to WAV file to database conversion. This was the proprietary part of our old setup. Can you help? </question>

<answer>This is typically done with a modem that allows digitised audio playback and incoming voice digitisation. Most modern internal and external modems do it now. It's just a matter of the software. On the server side, you probably want to look at mgetty-voice (for Linux): http://home.leo.org/~doering/mgetty/. There will be many ways of doing this, but mgetty-voice seems to be the standard underpinning for this type of service on Linux. Next, you need the logic/programatic control of the voice modem. You could probably script something easily to work with mgetty-voice. But here's something that already does something like that called vgetty_web. Just search for"vgetty" or "mgetty-voice" on sourceforge.net and check out the other stuff out there. There are some good `how to' tips for setting up a Linux-based answering machine if you go to: http://ilug-hyd.org.in/lamhowto.html and to http://frank.harvard.edu/~coldwell/answering_machine/ The sound files you generate as WAVs could be stored quite easily into a mysql database in a binary field. It may be worth doing some sort of compression to MP3 or Ogg Vorbis to save some space. </answer>