Answers 109

From LXF Wiki

Answers 109

<title>HotPicks installation</title>

<question>I finally took the plunge and installed Mandriva 2008 Powerpack on my Toshiba Laptop (Satellite M50 PSM53A). Everything works great that I have noticed so far, except that I think I may have a software modem, I'll have to work around this, I guess. I thought I'd install GCstar and Genius from LXF102. After several frustrating hours in the Software Management utility, the instruction manuals and the Mandriva website, I came to the conclusion that the Mandriva people only want you to use the programs that they make available. The same seems to be true for the other distros. Please tell me I'm wrong! If not, why is this so? How can I tell whether the software made available in your magazine is suitable for my particular distro. It also seems to matter whether I have Gnome or KDE desktops, how do I tell which desktop the software is for? If I were to install the Gnome desktop on Mandriva, would I be able to swap between Gnome and KDE like you can with Fedora? </question>

<answer>The various distros work hard to make installing and using software as straightforward as possible. To this end, they provide huge repositories that contain almost everything you could need. These packages are tested to make sure they are compatible with that distro and each other. As a result, installing from the distro's package manager is usually very simple, with all the details of dependency resolution, package downloading and software configuration hidden from sight. So it is true that the distro makers would prefer you to stick with their repositories, but this does not make installing software from elsewhere impossible. Some package managers are able to install from individual package files, although this often requires a trip to the command line. With Mandriva, you use the urpmi command from a root terminal

urpmi some-package.rpm

This only works with packages in the correct format for the distro: RPMs for Mandriva, Fedora and SUSE; Debs for Debian and the Ubuntus. It does have the advantage that the installed packages are included in the distro's database, so it can track what you have installed. However, the two you mention are only available on the DVD as source code and need to be compiled before you can install them. In the case of GCstar, there is a files called INSTALL.txt on the DVD, which explains how to install it. For Genius, and the majority of programs, there is an INSTALL file in the tarball that explains how to install it. The general procedure is

tar xf /media/dvd/Hot_Picks/Genius/genius-
1.0.2.tar.gz
cd genius-1.0.2
less INSTALL
./configure
make
su -c "make install"

These commands unpack the archive, switch to the directory holding the contents of the archive, display the INSTALL file, configure the build process for your system, compile the programs and install them respectively. Installing the compiled software requires administrator privileges, hence the use of su. Ubuntu users should replace the last line with

sudo make install

You may need to install GCC, the compiler software, before you can do this. The ./configure command will check if this, and any other required software, is available and warn you if not. Source code distribution is the most distribution independent method, so it should work on any distro and with any hardware (but it does require a bit of extra effort). As far as running KDE and Gnome software is concerned, as long as you have the correct libraries installed, and most distros cover this, you can run KDE software on a Gnome desktop and vice versa. You can install Gnome on Mandriva and choose between it and KDE when you log in, but you don't need to switch desktops to run software for the other one. The only real problem with running KDE applications on Gnome is that they look out of place. The same is true with Gnome programs on KDE, but there is a KDE module to apply the current KDE theme to Gnome/GTK programs too. The GTK-Qt Theme Engine is available from http://gtk-qt.ecs.soton.ac.uk. </answer>

<title>Bad, bad IPL</title>

<question>I have a cheapo Time AMD 64 laptop with Windows XP and usually Mandriva dual-booted. I occasionally try other distros on it, sometimes alongside with Mandriva and sometimes replacing it for a while. This week I tried to load Foresight linux, using the existing linux partitions and choosing the default option for the bootloader. On restarting the machine, however, I just get the error message `Bad IPL' `Press any key to reboot' Then nothing happens. Google tells me that IPL means `Initial Program Load' which doesn't mean much to me. I did try reloading Mandriva but still no result ­ same error. I'd like to try to salvage my Docs/ Pics/ and music, but more important for me is my email and news, which is in a RISC OS partition on Win XP. I'm tempted to try Insert (from LXF105) but I'm not sure this would do what I need. </question>

<answer>The Initial Program Loader is the first stage of the bootloader. This is the code that loads the rest of the bootloader, which then presents you with the boot menu. The IPL has to fit in the Master Boot Record (MBR) of the hard disk, where it has all of 446 bytes available ­ that's less than half the space it took you to describe the problem, so you must forgive it for not including more descriptive error messages. It would appear that your bootloader code is corrupt and the error you are seeing in fact comes from the BIOS. You can reinstall the bootloader by booting the disc in rescue mode. Type linux rescue at the boot prompt. This will mount your Foresight installation at /mnt/sysimage, from where you can reinstall the bootloader to the Master Boot Record with the following command

cat /mnt/sysimage/boot/extlinux/mbr.bin >/dev/sda

This assumes you have it installed on the first (or only) hard disk. Now exit the rescue shell by typing exit or, if you are lazy like me, pressing Ctrl+D, and it should reboot correctly. You other option is to switch from using Extlinux to Grub. Foresight installs both but only configures the bootloader you choose, so Grub has only a template menu file. If you are familiar with the syntax of the Grub menu, or you want to read up on it at www.gnu.org/software/grub/manual, you can edit the file and install it by booting the rescue disc and entering the installation with chroot, like this

chroot /mnt/sysimage
nano /boot/grub/grub.conf
# edit the file and press Ctrl-X to save and exit
grub-install /dev/sda

Press Ctrl+D twice, once to exit the chroot and again to exit the shell, and the computer will reboot, this time to a Grub menu. If you are not comfortable editing the Grub menu, you could simply reinstall Foresight but this time select Grub instead of the default bootloader of Extlinux. I don't normally advocate reinstalling a system as a means of addressing particular problems, but in this case you haven't used the system (because you are unable to start it) so you have nothing to lose. Most Live CD/DVD distributions will let you mount your Windows partition in order to back up your data. </answer>

<title>Adding wireless</title>

<question>Following a recent LXF article's advice I bit the bullet and bought a Dell laptop. Not the one in the feature ­ that one was sold out ­ but its successor, the Inspiron 1525. It's happily running Ubuntu, and it's the first wireless device I have. So I need an access point. I already have a network in place, with a LAMP setup that's also a firewall and router to the internet. But I don't know where to start with the wireless. I googled and read product reviews, and I see a lot of devices that are an access point, switch and router or just an access point, but I can't figure out where that sits in my network. Is it possible to use an access point/switch device, like (for example) the Linksys WRT54GL to extend my wired network to wireless via the switch function? I know it's a router, but I want it to be a switch, so that the wireless is in the same 192.168.2.0/24 segment. If I install it as a router, I'd have to go through double NAT to the internet, which makes it impossible to connect to a remote desktop at work from home. Would it work through a concrete floor so that the wireless extends to downstairs? </question>

<answer>You need a plain wireless access point. This connects to your existing wired network at your router or switch, and extends it into the wireless realm. While it would be possible to use an all-in-one router and access point (and even modem) for this task, you would need to disable the bits you don't need, making it a more complex setup than using a plain access point. The access point handles the wireless connection and encryption, while everything else uses your existing wired setup. One thing to watch out for is that wireless access points generally have a built-in DHCP server. If you have an existing DHCP server in your router, disable the access point's DHCP as having two independent DHCP servers on a network is asking for conflicts. All the access points I've used have a web interface (which you have to access for the wired network) where you can turn off DHCP. Range is a difficult topic, anything thicker than air between the access point and laptop will reduce your range to an extent. Also, most omnidirectional antennae are only omnidirectional in the horizontal plane with limited vertical coverage; a higher gain antenna increases this effect. A patch antenna is a directional device that allows you to adjust horizontal and vertical coverage, although some experimentation is required to find the best position. Since you may need to replace your antenna to improve coverage, make sure the access point you choose has a removable antenna. Most do, but there are a few with fixed antennae. </answer>

<title>To the nines</title>

<question>I'm sure you remember one of the usual bugs in the boot stage that fails to load the kernel, this happening usually when upgrading kernels but neglect to call Lilo. Grub is another story of course. Well, when the kernel is not found, we see 9s all over the screen. But why 9s? Why not 6s or some other number? Since the loader is pointing to the wrong sector shouldn't the screen present random data even as raw numeric values? </question>

<answer>The nines are not random: they are a Lilo error code. As Lilo loads itself it writes the word Lilo to the screen, one letter after the successful completion of each stage. If it fails at any of these stages, it outputs a two-digit hexadecimal code to indicate the error. Error code 99 means "invalid second stage index sector" in other words, it cannot find the location on your filesystem that contains the rest of the Lilo code. The error message is repeated, which is why your display fills with nines. Lilo does not use filesystem code to locate files; instead, the physical block address of the code it needs is written with the bootloader code. That's why you need to rerun Lilo after making any changes, be it editing the menu or installing a new kernel. Otherwise, the bootloader looks for its code in the wrong place, sees that this is not the code it needs and outputs the error message of 99. The screen does not show random data because, while Lilo is simple, it is not stupid, and it realises that this is the wrong location. The options, as ever, are to rerun Lilo every time you upgrade your kernel, change the menu or switch to Grub, which, while it still has terse error codes, does at least make them a little more comprehensible. </answer>

<title>Thoroughly modem</title>

<question>I've been having a look at Linux as a replacement for Windows XP and have been very impressed with the availability of the range of software, however I can't get access to the internet. I have an external 56k modem and the few Linux distros I've tried won't recognise the modem. As a newbie to Linux I'm really in the dark on this issue and find the available support info confusing or lacking. Can you help point me the right direction? </question>

<answer>Is this a serial or USB modem? If it's a plain, old-fashioned serial modem, then things couldn't be simpler. The first serial port is /dev/ttyS0 (the equivalent of COM0 with Windows), and you just need to set up your dialler program to use this. Which dialler program you use depends on which distro and, more importantly, which desktop you use. With KDE you should use KPPP, while in Gnome you should go to System > Administration > Network and choose the Point-to-Point or Modem option. If the modem is a USB device, you may or may not be in luck. USB modems are a little like internal modems, in that some just work and are supported by the kernel; others require specific drivers that may only be available for Windows; while many fall in between and can be made to work with a little effort. Use the lsusb -v command to find out the details of your modem, then use Google, or any other search engine, to find information on this device and Linux. This should tell you whether it should `just work' require a driver or if it is a lost cause. A quick test is to run

tail -f var/log/messages

in a root terminal (prefix the command with sudo if using an Ubuntu variant) before you connect the modem, then watch the messages as you plug it in. If the make and model are recognised, things are looking good. If the device dev/ttyUSB0 appears, you are really in luck and can use this as the modem device in the dialler program, just as for a serial modem. Otherwise, some web searching will be required. </answer>

<title>Card tricks</title>

<question>I am quite keen to buy a laptop like the Asus Eee PC, but I wonder about the use of SD cards for memory expansion. On the Panasonic home page there is a formatting tool available for SD cards. Apparently Windows does not do it properly. Is that an issue with Linux systems as well? And is it a general problem or just related to the use of SD cards in cameras? </question>

<answer>To clarify things first of all, the Eee can use an SD card as storage space, but not as memory (unless you use it as swap of course, but that would be very slow). Memory is expanded by replacing the SO-DIMM memory stick inside the computer, as detailed in LXF106. As for using SD cards for storage, they generally come preformatted with a standard FAT filesystem, but my preference is to format them in whichever device I intend to write to them in, such as my camera or PDA. I have never come across a problem reading such a card in Linux. If you want to use an SD card as an extra drive in an Eee PC, you would be best off reformatting it using a Linux filesystem. Ext2 is probably best for this, as the lack of a journal reduces the number of writes to the card as well an increasing the space available for storage. The Eee can use SDHC (Secure Digital High Capacity) cards; I've used an 8GB card in mine. Beware though that these are different from normal SD cards, even though they look the same, so while you can use one in your Eee, you would need a compatible card reader (and most of them are not) to transfer data from your desktop computer using one. </answer>

<title>Flashy but useless</title>

<question>I have a Sony Vaio VGN-N385N laptop and can run any KDE distro up to 3.5.8 or any Gnome distro with no problems at all. The problem is that any KDE 3.5.9/4.03 or any new Gnome distro (including Foresight on LXF106's DVD) just won't run. I install them on my hard drive with no problems but the minute they start the boot process they freeze. The Grub message comes up and counts down, it goes into the page with the distro's graphics and the coloured bar flashing horizontally across the screen ­ and then nothing! This happens with Ubuntu, Kubuntu, Mandriva spring and now Foresight. Is there something different with the bootloader that I need to change? </question>

<answer>This is failing far too early in the boot process for KDE or Gnome to be involved. Similarly, the bootloader is not a factor: once it has passed control to the kernel, which happens before the boot splash screen comes up, it takes no further part in the proceedings. I suspect that your problem is caused by a later version of some hardware-related system software, either the kernel or something like HAL or udev, not getting on with your hardware. However, this is only a suspicion, and you need to find out what is breaking during boot. The pretty splash screens that most distros use do a good job of hiding all the scary text output from a standard boot process, but that text almost certainly shows the source of your problem. Some distros have some sort of `safe mode' boot option that disables the splash screen, while others allow you to remove the splash screen during boot with a keypress, usually Esc or F2. If you can do this, you can usually see the point of failure, which often means you are 90% of the way towards fixing it. If there is no option to disable the splash screen, you can do it from the Grub menu. Press E (for edit) while the default menu option is highlighted, move the highlight over the line beginning with `kernel' and press E again. The kernel line contains a number of options; the only ones you need to touch relate to the splash screen. For example, on Ubuntu it looks like this:

 kernel /boot/vmlinuz-2.6.22-14-generic
 root=UUID=xxxx ro quiet splash

Remove the quiet and splash options, press Enter to stop editing and then press B to boot with the changed options. Some distros also have a separate quiet option on separate line. You can disable this by highlighting it and pressing D. You should now see a lot of text flash past, most of which is unimportant. What matters is the last few lines before things stop. Search Google for the last error message to find a solution, or post to the LXF forums at www.linuxformat.co.uk. Before you do that, there are a couple of boot options worth trying, as they solve more hardware-related boot problems that all the others put together. After removing quiet and splash from the kernel line, add noapic acpi=off. Note the different spelling. Despite the similarity, these are two very different options. If you can boot with these, try with each one individually. When you find the best set of options, you can edit the menu file at /boot/grub/menu.lst to make the change permanent (you will need to be root to do this). </answer>

<title>Motherboard support</title>

<question>I am running OpenSUSE 10.2, but the OS doesn't go too well with the Asus P5KPL motherboard of my new machine. Which Linux distros get on best with it and will in be able to use Planner on it, too? </question>

<answer>Mainstream manufacturers like Asus are generally well supported, because of the large number of people using them. However, it can take time for support for new hardware to make it into the kernel, and then for a distro to release a version with that kernel. Most distros release twice a year, and with the testing cycle that precedes release it can be nine months before new hardware is supported in your latest distro's release. The Asus P5KPL contains nothing particularly esoteric, so it should be supported by most current distros. The key word here is current: OpenSUSE 10.2 was released in December 2006, so support for anything less than 18 months old is likely to be problematic. Installing any more recent distro is likely to solve all your hardware compatibility problems. Some distros have a hardware compatibility section on their website, where you can check before downloading and installing. For example, OpenSUSE has one at http://en.opensuse.org/HCL and Mandriva's is at www.mandriva.com/hardware. Many distros provide Live CD versions, which are a good way of making sure everything works before installation. Planner should work with any distro that includes the Gnome libraries. It is included in the OpenSUSE repositories, so you can install it from Yast in the usual way. </answer>

<title>Video recovery</title>

<question>I installed/upgraded from Ubuntu 7.10 to 8.04 and made a mistake with my screen display. It's now widescreen and is unreadable. I can go to recovery mode but that doesn't help, so I need a line in the root window to restore to, say, VESA 800x600 mode. </question>

<answer>There is indeed a one-line solution: go into a terminal and run

sudo dpkg-reconfigure xserver-xorg

This will run the configuration utility for the graphics system, where you can choose the correct settings this time. Not only does it help you when things break, it also means you can experiment with your settings secure in the knowledge that if you mess things up, rescue is at hand ­ an ideal situation for those of us who practice provocative maintenance. </answer>

<title>Retrieving Grub</title>

<question>At present I dual boot between XP Pro on drive C and PCLinuxOS on drive D. It's time for a reinstall of XP, but I have PCLinuxOS set up pretty well the way I want it and don't want to start all over again with it. I also don't want to lose the dual booting. Is it possible to perform a complete reinstall of XP without losing the dual booting? Or is there a way that I can restore the dual boot after XP installation ? </question>

<answer>Installing Windows will get rid of whichever bootloader you use for Linux (Grub in the case of PCLinuxOS). This is why, when setting up a dual boot machine, it is always best to install Windows first. However, it's a simple task to restore your boot setup, because Windows will only overwrite the bootloader code in the disk's Master Boot Record (MBR), it will not touch your menu configuration. To restore your dual boot, you need to run Grub, which you can do from almost any Live CD distro. Boot from the CD (or DVD), open a terminal and log in as root by running su or sudo bash if you use an Ubuntu CD. You can run the automatic install script as

grub-install /dev/sda

although this does not always work well with multiple drive systems. The alternative is to install it manually, which requires only two commands anyway. You need to identify your drives and partitions, because Grub uses a different labelling scheme. The first hard drive is (hd0), the first partition on that drive is (hd0,0). Note that Grub counts from zero. The two locations you must identify are the location of the /boot/grub directory, which will be (hd1,0) if it is the first partition of the second drive, and where you want the bootloader code installed, which is usually (hd0), if you want to put it in the MBR of the first drive. Once you know where everything goes, run grub to enter the Grub shell, then run

root (hd1,0)
setup (hd0)
quit

The first command identifies the location of the Grub files, the partition containing the /boot/grub directory; the second command writes the initial bootloader code to the MBR, the meaning of the third command will be left as a mystery. Provided this all ran with no errors, a reboot should show your original boot menu in all its glory. Alternatively, you could save yourself a lot of grief and remove XP entirely. </answer>

<title>Control a remote machine</title>

<question>I have a PC in my father's home that I do not want to leave on 24 hours a day. So I would like to be able to turn it on and shut it down from my house. That computer is running Windows XP, while I am using Slackware 12.0 here. Is this possible? </question>

<answer>All you need to turn the computer off is to run some sort of remote desktop software, then you can log in and turn off from the Start menu just as you would if you were sitting in front of the computer. If the computer is running XP Home, VNC (Virtual Network Computing) is a good choice. TightVNC (www.tightvnc.com) is an implementation of this aimed at slower internet links. Install this on the Windows computer and set the server to run on the Windows box. In this case, you need to forward ports 5800 and 5900 in your router and firewall. If you are using KDE, you can use KRDC to connect to VNC as well as RDP desktops, otherwise install TightVNC on your Slackware box and use that to connect to the Windows desktop. Turning the computer on uses a completely different technology called Wake-on-LAN. When the computer is turned off but still connected to power, it listens on its network interface for a `magic packet' ­ a specific sequence of bytes. When it receives this, it turns itself on. This requires support for Wake-on-LAN in the motherboard's BIOS. Most recent BIOSes support it, but it is often disabled by default, so you'll need to find the option in your BIOS setup menus to turn it on. If you have an onboard NIC, that's all you have to do, but if you are using a PCI network card you will need to use the supplied cable to connect its Wake-on-LAN header to the one on the motherboard. Wake-on-LAN uses port 9, so forward that from your router to the broadcast address for your network. This will only work if you have a separate modem/router that is always powered up. It must also connect to the computer via Ethernet, as Wake-on-LAN only works with Ethernet adaptors. Finally, you need the hardware address of the Ethernet adaptor on the Windows computer, which you can get by running ipconfig in a DOS box. With this information, you can run the wakeonlan script from http://gsd.di.uminho.pt/jpo/software/wakeonlan with

wakeonlan -i [ipaddress of server] [MAC address]

For example

wakeonlan -i 123.124.125.126 00:0C:29:55:B0:C1

The IP address you use with wakeonlan or TightVNC must be your external facing address, not the internal LAN address of the individual computer. Since most ISPs use dynamic addressing, you need to use one of the dynamic DNS services, search the web for them, to map a set domain name to the dynamic address, unless you are lucky enough to have an ISP that offers static addresses. Wakeonlan should work with your Dynamic DNS hostname instead of the IP address. If it does not, ping or dig the hostname to get an IP address. </answer>