Nvidia graphics driver halting boot

For discussing Linux compatible (or not) devices

Moderators: ChrisThornett, LXF moderators

Nvidia graphics driver halting boot

Postby Crispy » Mon Jan 07, 2013 1:06 pm

Hi all,

I recently bought a Nvidia Geforce GT640 and installed the driver xorg-x11-drv-nvidia from the rpmfusion repo's on Fedora 17 and rebooted only to find that it halts when booting. I thought that perhaps I needed to disable the nouveau driver, however pressing 'e' at grub I noticed:

Code: Select all
linux /boot/vmlinuz-3.6.11-1.fc17.x86_64 ... nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off vga=normal


which suggests to me that the nouveau driver has been blacklisted and therefore shouldn't be loaded by the kernel? To be honest I have no idea if thats correct and I feel completely out of my depth with this and so any help or advice would be really appreciated.

Also I tried booting an older kernel (which doesn't blacklist nouveau) but found that I lose picture completely - monitor says there is no signal!

Thanks in advance,
Chris
Crispy
 
Posts: 57
Joined: Mon May 31, 2010 6:35 pm

Postby Dutch_Master » Mon Jan 07, 2013 2:07 pm

No, blacklisting only prevents the kernel from loading the module at boot. If you manually load a blacklisted module, it'll still load (and be used by the kernel). Install the latest driver for your card from nVidia themselves:
http://www.nvidia.com/object/unix.html
Dutch_Master
LXF regular
 
Posts: 2456
Joined: Tue Mar 27, 2007 1:49 am

Postby Crispy » Mon Jan 07, 2013 2:40 pm

Thank you for your reply, unfortunately I cannot get access to my system as the boot either halts or I lose picture all together thus I am unable to install the driver from Nvidia. In looking on that website you gave, it appears that I installed a legacy version rather than the latest, so perhaps doing an update on the Nvidia driver will fix the issue, however I can't get access to my system in order to update it.

I have tried blacklisting the Nvidia driver (from the grub command line) instead however that gives no picture - monitor says no signal again.

I have just found a site on how to disable the X server and it talks about going into a different run level? Is it possible to boot into a different run level which is text-only? The site doesn't mention about booting into it just changing it once the system has booted.

Thanks,
Chris
Crispy
 
Posts: 57
Joined: Mon May 31, 2010 6:35 pm

Postby Dutch_Master » Tue Jan 08, 2013 1:51 am

You need to boot in "single user mode" or "rescue mode". It'll ask for the root password. Now, remove all packages related to the nVidia drivers via yum (don't use it, so someone else will tell you how to do that) and try to start X again (the startx command, IIRC). If that works, log out again. It shows that the X11 system is working, probably using the generic VESA driver. It also tells you that if anything goes wrong, the cause is the nVidia driver. Change into the directory where you stored the nVidia driver (it ends in .run) Make sure it's executable:
Code: Select all
chmod +x NVIDIA*.run
Then execute the installer:
Code: Select all
sh NVIDIA*.run
Use tab-completion to make this easier, just type "sh NV" (note: w/o the " please! ;)) then hit the tab key. It'll complete the name of the file for you. Nice feature, èh? ;) Accept the nVidia licence and let it run. Let it change the xorg.conf file.
Dutch_Master
LXF regular
 
Posts: 2456
Joined: Tue Mar 27, 2007 1:49 am


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest

cron