Any dnsmasq experts out there?

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

Any dnsmasq experts out there?

Postby paulm » Tue Apr 23, 2013 6:20 pm

I've (finally) got my combined server/nas up on my local network. Its running SMS, and provides file storage and DNS/DHCP services. Once I work my way through the config for CUPS and Samba, it should also be my print server.

However, I've hit a problem. Machines on my network are getting DNS services both for the local network and the internet. I've been able to ssh from my laptop to the desktop using the desktop machine's name. But I'm unable to access any of the services on the SMS machine by name. I can ping it by name, but I can't SSH to it, mount NFS shares, or access the web server other than by IP.

I suspect I've got something incorrectly set in my dnsmasq config, but having looked through it several times, I've not managed to find it so far.

dnsmasq.conf is as below:

Code: Select all
domain-needed
bogus-priv

resolv-file=/etc/nameserver.list
local=/ibmpeers.net/
domain=ibmpeers.net
dhcp-range=192.168.1.100,192.168.1.150,12h

dhcp-host=00:01:d2:04:0b:d8,openwrt,192.168.1.2
dhcp-host=00:14:BF:70:9B:36,unslung,192.168.1.77

dhcp-option=option:router,192.168.1.1


resolv.conf has only "nameserver 127.0.0.1" and the nameserver.list specified in the dnsmasq.conf is as below:

Code: Select all
nameserver 8.8.8.8
nameserver 8.8.4.4
domain=ibmpeers.net


So, is there enough information in this for anyone to spot my silly mistake? Or does anyone have any suggestions as to how I best troubleshoot the problem?

Paul.
paulm
LXF regular
 
Posts: 242
Joined: Mon Apr 03, 2006 4:53 am
Location: Oxfordshire, UK

Postby nelz » Tue Apr 23, 2013 6:58 pm

nameserver is not a valid parameter for dnsmasq, you should be using server. However, I generally keep it simple and leave this out altogether and put the router's address is resolv.conf, as the router caches external address lookups anyway.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8521
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby paulm » Tue Apr 23, 2013 10:19 pm

nelz wrote:nameserver is not a valid parameter for dnsmasq, you should be using server. However, I generally keep it simple and leave this out altogether and put the router's address is resolv.conf, as the router caches external address lookups anyway.


Thanks nelz. I'd missed the server instead of nameserver in my extra file.

Seem to have it working now, though I'm not sure why the change is required - the problem seems to have been in /etc/hosts.

I've changed it to read

Code: Select all
192.168.1.5      sms.ibmpeers.net sms


instead of the loopback address. Now its working - I can ssh into it by name, and also open the default sms web pages.

After several years of running Amahi with its bind dns server, dnsmasq is wonderfully quick on lookups, let alone once things are cached.

:) Now I need to move the box and sort out the printer....

Thanks again.

Paul.
paulm
LXF regular
 
Posts: 242
Joined: Mon Apr 03, 2006 4:53 am
Location: Oxfordshire, UK


Return to Help!

Who is online

Users browsing this forum: No registered users and 0 guests