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First Steps Beginner-level tutorials
for users dipping their toes into Linux

Sockso: Build a

Tired of having to transfer music around? Andy Channelle shows you how
to create a personal music server so you can listen to your tunes anywhere.

Our
expert

Andy
Channelle
Andy seems to
have been taking
his first steps in
free software
forever, and has
been interested in
technology since
the advent of the
Dragon 32.

e love music and we love computers. So put the
W two together and you have the perfect

combination. No, not Kraftwerk, but a server that
can stream your MP3 collection to any computer you use. In
this tutorial, we're going to download and install an open
source media server package, configure it to play our library,
design some playlists and remotely access these over a local
network. We'll also look at the potential for accessing your
collection from outside your home network.

The software we're using for this project is called Sockso

and the latest version, 1.1.8, is available from http://sockso.
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) You can access your music via this smart-looking website.
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) Create your server accessible playlists by dragging songs
from the file tree to the Playlist window.

pu-gh.com. Sockso s available for Linux, Mac and Windows,
and there's no installation as such. Instead all you need to do
is unzip the file to a suitable location and double-click either
the sockso.jar file or the linux.sh script. The JAR file
extension should warn you that Socksois Java-based
software, so if you don't have it already, find and install version
1.6 of Java Runtime through your package manager.

When you fire up Sockso for the first time you'll be
presented with the main interface. This has a series of tabs
running across the top, a note of your current IP address at
the bottom and a two-pane section in between. These will
eventually be used to access your library and to construct
playlists, but at the moment they both look a little desolate.
We need to add some music.

Hey Mr DJ, put a record on

To begin adding tracks, select the Collection tab from the top
of the window. Here you'll see a large window and a pair of
buttons that are used to add and remove folders from your
collection. Click the Add button to launch a file browser and
navigate to your music collection. This tool imports
subfolders, so there's no need to import albums individually -
just choose the parent music folder and everything beneath it
will be added to the server. Well, links to tracks are created
within the software’s database — the files aren't actually
copied to the new location.

We added the folder ~/home/user/Music (where /user
is the server admin’s username) and it took about three
minutes to add 3,600 songs to the database. You may find it
takes longer to parse larger collections, so you could consider
leaping beyond these first steps and installing Sockso with a
MySQL back-end to make it easier to handle big collections.

By default, Sockso will scan any folders added every five
minutes for new tracks. This seems rather excessive, so you

Last month \We got organised with Basket Note Pads and OOo outlines.
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MusIC server s

can change it to scan every hour by going into the General tab | i ms i foms | Ggonssi { §oms mgma
and setting Scan Interval to 60. If you add tracks later and kil :
want to update quickly, go to Collection and select Scan Now. s s
Oh, and while you're in the General tab, why not rename the - =SS5 If you're up for a bit
server with a tasteful name, such as The Unstoppable LXF i of code hacking,
Music Machine? e youcanfindallthe
It's time to test the server, so fire up your browser and e e design infofmation
) e for Socksoin the
type http://localhost:4444 into the address bar. If e application/
everything's working correctly, you'll see the standard Sockso e = {} resources folder.
interface, which presents you with various links under the R
splashy header and an alphabetical strip on the right-hand kil |
side of the window. Selecting a letter takes you to a list of —
artist names that begin with that character - to the right of
each artist name is the number of albums available and to the ) You can disable downloads to ensure you won’t end up
left are a trio of icons. The first will play everything under that ~ with lots of copies of your music everywhere.
artist, the second adds the tracks to a playlist and the third
will download the track (you won't need to do this, as you're and to the right of this is User Playlists, which enables other
running a local version). Clicking on the artist's name will users create their own playlists via the web front-end.
present you with a list of albums and selecting an album Their efforts will appear in the Administration GUI within
displays the individual tracks. the Playlists tab, so if a remote user creates a particularly
You can also use the Search bar to look for a particular great playlist, you can copy it and make amendments. Just
artist or song. This is dynamic, so the list of available tracks drag it to the Playlist window (on the right), make changes
will be pared down as you type. and then save it with a new name.
Making playlists Network access
Now, wouldn't it be great to have playlists that are accessible Now imagine we're in a house where there are four users who
anywhere in the house? Well, Sockso makes it simple. Go want to access the server. If we're being completely open,
back to the Music tab and you'll see your music displayed on each person could direct their browser at the local IP address
the left-hand side. Click the disclosure icon (+) next to each for the server, but this is likely to be different to the address
artist to reveal albums and then the icon next to an album’s Sockso shows. You can find a machine’s IP address in a
name to see its tracks. From here, you can drag tracks to the terminal by typing ifconfig. Enter this address into your
window on the right. Songs can be re-ordered by dragging browser, followed by :4444 — the port the server's running on.
them up or down and deleted with the Delete button. We want to ensure each of our users logs in to access
Once you're satisfied, click Save Playlist and give it a music and restrict downloads. To do this, go into the Users
name. To see your playlists, click the Playlist tab above the file  tab and click the Create User button. Provide a username,
tree. To edit one, click and drag it to the right-hand pane. Once  password (twice) and an email address, then click on Create
you've altered your playlist, click Save Playlist again and type User. Before leaving this section, click the Require Log In
in the amended playlist's name. button. Complete the process by going back to the General
Return to the server and click the Playlist link. The playlists ~ tab and selecting Disable Downloads. You've now created
you've created will be listed under the Site Playlists section your own home network radio station. Smashing!
calhosu4444fplayer /xspfjar34i 778
— ..M Playback
:. B:E: ZZLL'ZZ _- ::.ER el ; By default, any playlists and files you Flash, there are other options including
\ |EEEEE e R select to play will be opened inapop-up  streaming to various applications, such
:: z:: ::tzz = z:r FGL :;: CT: :D D: : DP ECDO —— Flash player. This worked on every as iTunes and Windows Media Player, or
& BEN FOLDS - KATE machine we attempted to connect on, using an embedded player.
; :: 2:: ::tzi - il";ﬁ"; — regardless of operating system, and also The Flash player displays the playlist,
d 1| v R enables you to start a long playlist and enabling you to select tracks to play, a
10. BEN FOLDS - BATTLE OF WHO COULD CAF then navigate away from the Socksoweb  set of transport controls for navigation
e interface without losing your music. and any associated album art for the
However, if you have a problem with track currently playing.
) The pop-up player is functional without being too bland.
If you missed last issue Call 08/0 837 4/73 or +44 1858 438795.
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Basket: Order

Basket can do more than to-do lists — it's also an ideal research tool.

Save your baskets
file in a Dropbox
(www.getdropbox.
com) folder so you
can access them
from any computer.

) Using the small
minus icon, you
can collapse a
list down to just
its title with a
single click.

to-do lists and simple notes. Now we want to revisit

this powerful application to look at other ways it can be
used to organise, manage and share information. Specifically,
we're going to look at the software as a research tool, which
could be useful for writing a novel, preparing a report,
designing a presentation or planning a household project.
We'll also look at acquiring, editing and organising notes,
importing information from a variety of sources, sharing
information with friends or colleagues and using Basket Note
Pads to present your research to others.

L ast month, we built a basic Basket system to deal with

Preparing the app

First, create a new basket, which can be done by right-clicking
the Baskets list and selecting New Basket, or by pressing
Ctrl+N. Customise it using the various options — we've gone
for a freeform basket — then provide a suitable name and
click OK. The space on the right will become the active basket
and this can be reconfigured by right-clicking the name and
selecting Properties. We can give the basket a title by right-
clicking anywhere within the space and selecting the Text
option. This will add a space where you can type in some text
and format it using the options at the top of the window.

We can also add lists (see LXF120 for more on this), group
them together to make your basket management easier and
add additional text elements too. Having added a few objects
to the window, it's a good idea to practice moving them
around, because what gets moved depends on where you
grab an object. For instance, if you've grouped items together,
you can remove an object from the group by hovering next to
its name (the blue highlight will only cover that item) and
dragging it away. This is also how you reorder items in a stack.
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) It's Basket's ability to work with web-based content and
other apps that makes it so useful as a research tool.

Shift the mouse slightly to the left and the highlight should
cover the entire group, which can then be dragged elsewhere.

The next thing we want to add is an image, which is done
by dragging and dropping an image file from any folder into
the active basket. When doing this, you'll be asked if you want
to copy or move the picture. Move will delete the image from
its original location, so you'll probably want to select Copy.
Once in the basket, an image can be moved around just like
anything else. We've created a title for the image and then
grouped the two elements together, which can be done by
either selecting both objects (click the first then Shift-click the
second) and then clicking the paper clip icon in the toolbar, or
by dragging one element so it attaches to the other (you'll see
a thick black line appear beneath the original object). The
second method means it's possible to, for instance, collapse
the image beneath its title using the small minus icon. In this
way it's possible to build up sophisticated stacks of content
and then reduce them down to a title with a click.

Being visual

If you want to edit the image, you'll need to double-click on it
to open it in a suitable editor. When you're done, your
alterations are automatically saved to the Baskets version,
which saves you importing the image twice.

We can also create associated links with our image (or a
piece of text) by first selecting it — hover over it until the
border appears and click it — then going to Insert > Link and
providing the appropriate information. The link will become
an appendage of the original text or image, meaning it will
collapse using the minus icon as before. In our research
basket, we've made a section called web links to house our
collection of links associated with the project.

However, in-depth research relies on gathering information
from a variety of sources, so look to the walkthrough for more
on how Baskets integrates with other Linux apps and Firefox.

Never miss another issue Subscribe to the #1 source for Linux on page 102.
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your research

'7 y Step by step: Gathering research
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Drag and drop a link

To archive useful links you've found on the
internet, navigate to the location you want

to save, grab the favicon (the small icon

next to the address bar) and drop it into

your research basket. The link will then be
formatted with the name of the page and can
be moved around just like any other element
within Basket Note Pads.

F R

-|=--
e N

el Syrrrre

Bty L Serroie Sasver ored Tha bam Femiy

bl s, ol e e
ures gy Pkt wroan g

P gy EE By
e e 1T
SrE s e
nE

B Take text from the web

If you find a particularly useful piece of text
on the web, highlight and drag it from your
web browser (or an application) into your

basket, where it will appear as a new element.

Note that this kind of text doesn't retain any
information about its origin, so it might be
best to also add a link to the original source.
This text can be edited in the usual way.
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Take a screenshot

The problem with links is that they might
expire or the text may change. A way around
this is to take a screenshot of the site. Right-
click a space in the basket and select Grab
Screen Zone. Basketis minimised and the
cursor turns into a crosshair. Draw around
the page you want to save and it will be
inserted into the basket.
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B Export a HTML page

HTML is a great way of backing up or sharing
baskets with a friend or colleague who
doesn't use Basket. Just navigate to File >
Export > HTML Page and define a location
for the file. This creates a single HTML file
and a folder of the assets associated with it.
Links in the basket will remain active, making
this a good, if simple, web editing app.

B Build a colour palette

If you use this software to manage a design
project instead, it's possible to build up

a colour palette by sampling areas of the
screen. So, you could open up a logo on
your desktop in Gimp, select Insert > Colour
From Screen and use the pointer to pick out
acolour. The result is a swatch along with a
hex value for the colour.

B Create an app launcher
Finally, you may want to have applications
associated with a piece of research - for
instance, CeltX could be useful if you're
writing a screenplay. To do this, right-click
and select Launch. Either select your app
from the list or browse to it using the ellipsis
(-..) icon. Now click OK to create a button that
will launch your application.

Next month Share more than just music and configure an effective firewall.
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